Loading...

All project content is available for reading, but you need to be a member of the project for Subversion checkout of source code, or to create/modify any information.
Login if you are a member. Apply here to request membership (open to all).

Ticket #69 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Java script Error in QuickSearch.aspx

Reported by: grenersen@… Owned by: fredrik@…
Priority: blocker Component: QuickSearchExtender
Keywords: Cc:

Description

I have followed the Troubleshooting and added the code to my global.asax.cs file and compiled the project. But I still get a javascript error saying "sys" is undefined. I run SP3 of EPiServer CMS5 on WindowsXP SP3.

Any clues?

PS. I really want to make a screencast of the module (this time with speech and music:-)

Change History

comment:1 Changed 9 years ago by henrik@…

  • Owner changed from henrik@… to fredrik@…
  • Status changed from new to assigned

comment:2 Changed 9 years ago by fredrik@…

Are you sure you are running the project in .net 3.5? In Visual Studio, right click and select Properties on the project, check "Target Framework" under "Application" and make sure it's .Net Framework 3.5.

To verify, search for "system.web.extensions" in the web.config and verify it's running version "3.5.0.0".

comment:3 Changed 9 years ago by grenersen@…

I installed the module via the Manager Installation *.zip file and checked the different configurations you had specified. In my web.config I have several references to "system.web.extensions" and the version is 3.5.0.0.

A reason for the error might be that I have to compile the project with VS 2008 since I made a change to the Global.asax.cs file?

Tnx for the speedy reply!

comment:4 Changed 9 years ago by grenersen@…

I have now upgraded to VS 2008 and compiled the project due to the change in Global.asax.cs. Where I previously had an java script error message saying; "sys is undefined" I now have "dropitquicksearch is undefined".

I have set the target Framework in under properties in VS to be 3.5 and verified that I have references to the "system.web.extensions" for version 3.5.

Any clues?

comment:5 Changed 9 years ago by steve@…

This is the same error I had, but I fixed it by following the steps in the Troubleshooting section. I needed to repair my Metabase (I'm running XP) and add the code to global.asax.cs.

Additionally, make sure the <location ... section is correct (mine was not):

<location path="QuickSearchExtender">
<system.web>
    <authorization>
        <allow roles="WebReaders, WebAdmins, Administrators" />
        <deny users="*" />
    </authorization>
</system.web>
</location>

comment:6 Changed 9 years ago by fredrik@…

Could you please verify where you get the error? On the QuickSearchExtenderService.svc file or the QuickSearchExtenderService.svc/js file?

comment:7 Changed 9 years ago by grenersen@…

  • Status changed from assigned to closed
  • Resolution set to fixed

Problem is now solved. I am not sure what did it in the end (as I had followed the Troubleshooting from start to end. My guess is that running CleanIISScriptMaps.exe from the Command prompt rather than the *.exe file itself solved the problem.

Thank you for all your patient and speedy replies. I will now go about making a video of the module in use!

Note: See HelpUser/Tickets for help on using tickets.