Loading...

All project content is available for reading, but you need to be a member of the project for Subversion checkout of source code, or to create/modify any information.
Login if you are a member. Apply here to request membership (open to all).

Ticket #325 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

non-ASCII characters in Linked Image Wizard properties breaks XML-encoding in LinkedImageCreator

Reported by: per.atle.holvik@… Owned by: thomas.leela@…
Priority: critical Component: ImageListProperty
Keywords: xml-encoding unicode Cc:

Description

Hi,

I've found that when e.g. the Text property of the Link of the Linked Image contains a non-ASCII character, say 'é', it breaks the LinkedImageCreator.aspx (see attached screenshot). 

I've tried encoding the property (using XmlWriter) in the GenerateXML method of LinkItem.cs, but still the page breaks.

Any tips on how to go about fixing or circumventing this would be much appreciated

Regards,
Per Atle Holvik

Attachments

ImageListProperty XML encoding issue - screenshot 1.png (58.3 KB) - added by per.atle.holvik@… 5 years ago.
ImageListProperty XML encoding issue - screenshot 2.png (88.1 KB) - added by per.atle.holvik@… 5 years ago.

Change History

Changed 5 years ago by per.atle.holvik@…

Changed 5 years ago by per.atle.holvik@…

comment:1 Changed 5 years ago by thomas.leela@…

  • Owner changed from mari@… to thomas.leela@…
  • Status changed from new to assigned

comment:2 Changed 5 years ago by thomas.leela@…

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:3 Changed 4 years ago by thomas.leela@…

Previously the persisted xml was properly escaped. Now also quotes used in js are escaped.

Note: See HelpUser/Tickets for help on using tickets.