Loading...

All project content is available for reading, but you need to be a member of the project for Subversion checkout of source code, or to create/modify any information.
Login if you are a member. Apply here to request membership (open to all).

Ticket #31 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

Error when loading page with MultiPage property

Reported by: kristian.gimring@… Owned by: steve@…
Priority: major Component: MultiPageProperty
Keywords: Cc:

Description

I get this error when using a MultiPage property. It works fine in my development environment, but not after deployment.

I entered one external link in the popup.

---
Name cannot begin with the '"' character, hexadecimal value 0x22. Line 1, position 43.

Excepted Stack Trace:

[XmlException: Name cannot begin with the '"' character, hexadecimal value 0x22. Line 1, position 43.]

System.Xml.XmlTextReaderImpl.Throw(Exception e) +87
System.Xml.XmlTextReaderImpl.Throw(String res, String[] args) +77
System.Xml.XmlTextReaderImpl.Throw(Int32 pos, String res, String[] args) +18
System.Xml.XmlTextReaderImpl.ParseAttributes() +1899708
System.Xml.XmlTextReaderImpl.ParseElement() +545
System.Xml.XmlTextReaderImpl.ParseElementContent() +461
System.Xml.XmlTextReaderImpl.Read() +26
System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace) +435
System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc) +50
System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace) +162
System.Xml.XmlDocument.Load(XmlReader reader) +96
System.Xml.XmlDocument.LoadXml(String xml) +194
Intergen.EP.Utils.MultipageLinkItemCollection.ParseCompositeString(String linkItemsString) +180

Change History

comment:1 Changed 10 years ago by steve@…

  • Owner changed from jerms55@… to steve@…
  • Priority changed from blocker to major
  • Status changed from new to assigned

This seems like something with the input string. Did you have " in the clickable text or link title?

For some reason, it cannot be parsed correctly. I need to test and try to reproduce it.

comment:2 Changed 10 years ago by kristian.gimring@…

I got rid of the error message somehow, but I can't recall how right now. I don't think I did anything specifically relating to the MultiPage property, so it may have been some bigger issue with the EPiServer installation.

comment:3 Changed 10 years ago by steve@…

  • Status changed from accepted to closed
  • Resolution set to worksforme

Cannot be reproduced, closing case.

Note: See HelpUser/Tickets for help on using tickets.