Loading...

All project content is available for reading, but you need to be a member of the project for Subversion checkout of source code, or to create/modify any information.
Login if you are a member. Apply here to request membership (open to all).

Ticket #299 (reopened defect)

Opened 6 years ago

Last modified 6 years ago

EPiImageResizer doesn't seem to work if image is located in folder with space in folder name.

Reported by: emanuelssonm@… Owned by: alexander@…
Priority: major Component: EPiImage
Keywords: EPiImage, EPiImageResizer Cc:

Description

When selecting an image that is located in a folder with a space in its name for the EPiImageResizer control no thumbnail is created. Perhaps related to ticket 292?

/Martin

Change History

comment:1 Changed 6 years ago by alexander@…

  • Status changed from new to closed
  • Resolution set to worksforme

Haven't been able to reproduce this bug in EPiImage 2.9.1.

comment:2 Changed 6 years ago by emanuelssonm@…

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Hello again,

I think I might have narrowed it down to when this happens. If you have a link collection property where you point out a number of images and then display them in for instance a repeater, images placed in folders with spaces will break for some reason, here is an example of a repeater where I've reproduced the problem:

<asp:Repeater ID="Images" runat="server">
	<ItemTemplate>
		<EPiImage:EPiImageResizer ID="EPiImageResizer1" ImageUrl="<%# ((LinkItem)Container.DataItem).GetMappedHref() %>" Width="120" Height="130" Transformation="ScaleToFit" runat="server" />
	</ItemTemplate>
</asp:Repeater>

Maybe not the most common circumstances but for us it breaks, do you have the possibility to try to reproduce this?

Best regards

Martin

comment:3 Changed 6 years ago by ulrika.lindeberg@…

Maybe this is another bug, but when we upgraded EPiImage, I can no longer choose any pictures to the gallery. Old pages still work, but as soon as I'm trying to add another picture to a gallery, all the pictures disappear when I save the page.
I have tried to pick pictures from the Documents folder instead of the Page Files folder, since there are no spaces in the folder name there, but it doesn't help me.

Note: See HelpUser/Tickets for help on using tickets.