Loading...

All project content is available for reading, but you need to be a member of the project for Subversion checkout of source code, or to create/modify any information.
Login if you are a member. Apply here to request membership (open to all).

Ticket #230 (new defect)

Opened 7 years ago

Last modified 7 years ago

Link detective does not works for secured site

Reported by: pankaj.k.prasad@… Owned by: Pankaj
Priority: major Component: LinkDetective
Keywords: Cc: pankaj.prasad@…

Description (last modified by steve@…) (diff)

Hi,
I configured the LinkDetective for an enterprise version site and found that for the secure site it does not works while same settings work for Public site.

Do i need to add credentials for access of secure sites?


LinkDetective.config file contents which i have configured for my Enterprise version site:

<?xml version="1.0" encoding="utf-8" ?>
<!--
=======================================================================================
LinkDetective
=======================================================================================
To get LinkDetective to only check the pages and properties you want, modify this config
file accordingly.

If you don't want LinkDetective to show "User prompted for EPiServer login" errors, simply
set ignoreloginerror to true.

For debugging purposes you can set the stopcheckingafterpage to e.g. 100 and LinkDetective will stop
extracting links after finding page number 100. (0 = no limit).

Also when debugging, if you don't want LinkDetective to check links by using HTTP
requests, set dohttpcheck to false.
-->
<settings ignoreloginerror="false" loginurlpattern="util/login.aspx" stopcheckingafterpage="0" dohttpcheck="true">


  <!-- 
  If you want to run LinkDetective under EPiServer Enterprise you need to specify
  the start page id for each site.
  E.g. <enterprise startpageids="3, 100" />
  -->
  <enterprise startpageids="1357, 20475" />
  
  
  <!-- 
  With the default settings reports are only kept in memory, and is lost if the server or IIS is 
  restarted, or if ASP.Net decides it needs the space. It is recommended to turn on write report
  to disk so that the latest reports always are available to the editors. This of course require 
  read and write permissions for ASP.Net to work.
  E.g. <writereporttodisk enabled="true" path="c:\LinkDetectiveReport\" />
  -->
  <writereporttodisk enabled="true" path="S:\LinkDetectiveReport\" />
  
  
  <!-- 
  If you would like LinkDetective to ignore certain page types, simply specify the PageTypeNames 
  of the page types you want LinkDetective to ignore:
  E.g. <ignorepagetypes pagetypenames="[Public] Standard page, [Public] News item" /> 
  -->
  <ignorepagetypes pagetypenames="" />

  <!-- 
  If you would like LinkDetective to ignore certain pages, simply specify the PageLink.IDs 
  of the pages you want LinkDetective to ignore:
  E.g. <ignorepageids pageids="3, 4" />
  -->
  <ignorepageids pageids="" />

  <!-- 
  If you would like LinkDetective to ignore certain properties, simply specify the names 
  of the properties you want LinkDetective to ignore:
  E.g. <ignoreproperties propertynames="MainBody, SecondaryBody " />
  --> 
  <ignoreproperties propertynames="GoogleMapsLocation" />


  <!-- 
  If you would like LinkDetective to ignore all urls starting with a certain
  text, add them here. E.g. if you want to exclude LinkDetective from checking
  all urls starting with https://, just add https://
  E.g. <ignoreurls startingwith="https://, http://www.google.com/" />
  -->
  <ignoreurls startingwith="" />


  <!-- 
  To check external links, LinkDetective tries to access the external URL by HTTP.
  If the link is to a big file, it will try to download the file and this might be very slow 
  and steal a lot of bandwith. Add the file extensions that LinkDetective should ignore.
  E.g. <ignorelinks withfileextension="img, bin, wmv, mp3, exe, zip" />
  -->
  <ignoreexternalfileurls withfileextension="img, bin, wmv, mpg, avi, mov, exe" />
</settings>

Kindly refer the screen attached to this incident.

Thanks in advance!

Attachments

linkdetective enterprise version issue.JPG (232.2 KB) - added by pankaj.k.prasad@… 7 years ago.
Screen showing Linkdetective Report for Enterprise site

Change History

Changed 7 years ago by pankaj.k.prasad@…

Screen showing Linkdetective Report for Enterprise site

comment:1 follow-up: ↓ 2 Changed 7 years ago by steve@…

  • Description modified (diff)

Modified description to make config easier to read.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 7 years ago by pankaj.k.prasad@…

I am not sure about the changes you asked to make but when i added the first line as

#!text/xml 

and last line as

I get error saying that line 1 is not correct format of XML which seems obvious to me.

Replying to steve@…:

Modified description to make config easier to read.

comment:3 in reply to: ↑ 2 Changed 7 years ago by steve@…

I was just editing this ticket, to make the xml you reported easier to read. This has nothing to do with the case you reported. Someone else will have to look into that.

Replying to pankaj.k.prasad@…:

I am not sure about the changes you asked to make but when i added the first line as

#!text/xml 

and last line as

I get error saying that line 1 is not correct format of XML which seems obvious to me.

Replying to steve@…:

Modified description to make config easier to read.

Note: See HelpUser/Tickets for help on using tickets.