All project content is available for reading, but you need to be a member of the project for Subversion checkout of source code, or to create/modify any information.
Login if you are a member. Apply here to request membership (open to all).

Ticket #208 (closed defect: fixed)

Opened 8 years ago

Last modified 7 years ago

Two EPiImage properties on one page only renders the last one

Reported by: steve@… Owned by: alexander@…
Priority: major Component: EPiImage
Keywords: Cc:

Description (last modified by steve@…) (diff)

I added two EPiImage properties to a page type, created a page and tried to show the values using the EPiImageResizer control.

However, only one control is showing the image. I have checked that the property names are correct. Both properties are showing an image in edit mode.

Change History

comment:1 Changed 8 years ago by steve@…

  • Description modified (diff)

comment:2 Changed 8 years ago by steve@…

It seems the problem is with image names that contain spaces. The value is stored in the property. Example:

The Resize control renders this:
<img src="/global/scaled/150x150x2/Global-Images-Sample-Enge%20org%20chart%20(94x94px).jpg" alt="My Alt Text" />

However, that image does not exist in the scaled directory. Seems the scaling function when inserting the image in edit mode does not like spaces in file names.

comment:3 Changed 8 years ago by alexander@…

Fixed in version 1.00

comment:4 Changed 7 years ago by alexander@…

  • Status changed from new to closed
  • Resolution set to fixed
Note: See HelpUser/Tickets for help on using tickets.