All project content is available for reading, but you need to be a member of the project for Subversion checkout of source code, or to create/modify any information.
Login if you are a member. Apply here to request membership (open to all).

Ticket #165 (closed defect: worksforme)

Opened 8 years ago

Last modified 8 years ago

Redirects also affects EpiServer virtual admin interface

Reported by: peter.thornqvist@… Owned by: peter.thornqvist@…
Priority: major Component: 404Handler
Keywords: Cc:


When running episerver admin on same server as website, the virtual URL functionality (ie Util/Login.aspx) stops working. I suspect it is because the 404 handler gets the error and redirects before EpiServer has a chance to do it. Any solution to this problem?

Change History

comment:1 Changed 8 years ago by steve@…

  • Status changed from new to accepted

Could you specify what version of EPiServer and the 404 handler you're using?

comment:2 Changed 8 years ago by peter.thornqvist@…

We are using the latest 404 from SVN and CMS5 .133. We are currently on IIS6 and the site is a real site, not a virtual directory

comment:3 Changed 8 years ago by steve@…

Hm, strange. The only reason the 404 should pick up the /util/login.aspx would be that asp.net or IIS cannot find it. As a VPP, at least asp.net should be able to see it.

Initially I thought this was the same as #128, but I guess it is not.

You could try to move the 404 module to the end of the HttpModules section so that it's event handler is registered last.

I'm assuming you have set up the wild card extension for IIS (against asp.net).

comment:4 Changed 8 years ago by steve@…

Did you solve this? Can I close this ticket?

comment:5 Changed 8 years ago by peter.thornqvist@…

  • Owner changed from steve@… to peter.thornqvist@…
  • Status changed from accepted to assigned

No, we still have the same issue. I have tried your suggestions without any luck.

This isn't a major problem ATM since we are running two websites; one for admin and one for normal use.

comment:6 Changed 8 years ago by oyvind@…

  • Status changed from assigned to closed
  • Resolution set to worksforme

Old ticket. Unable to reproduce this. Closing ticket.

Note: See HelpUser/Tickets for help on using tickets.